hdu 2055 An easy problem
C语言题库
共 1051字,需浏览 3分钟
·
2021-07-17 21:49
An easy problem
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 46083 Accepted Submission(s): 29716
Problem Description
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.
Output
for each case, you should the result of y+f(x) on a line.
Sample Input
6
R 1
P 2
G 3
r 1
p 2
g 3
Sample Output
19
18
10
-17
-14
-4
代码:
#include<stdio.h>
#include<string.h>
int main()
{
int n;
scanf("%d",&n);
getchar();
while(n--)
{
char a;
int y;
scanf("%c %d",&a,&y);
if(a>='a'&&a<='z')
printf("%d\n",y-(a-'a'+1));
else
printf("%d\n",y+(a-'A'+1));
getchar();
}
return 0;
}
评论