hdu 2123 An easy problem
共 1492字,需浏览 3分钟
·
2021-10-01 00:20
An easy problem
Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10669 Accepted Submission(s): 7288
Problem Description
In this problem you need to make a multiply table of N * N ,just like the sample out. The element in the ith row and jth column should be the product(乘积) of i and j.
Input
The first line of input is an integer C which indicate the number of test cases.
Then C test cases follow.Each test case contains an integer N (1<=N<=9) in a line which mentioned above.
Output
For each test case, print out the multiply table.
Sample Input
2
1
4
Sample Output
1
1 2 3 4
2 4 6 8
3 6 9 12
4 8 12 16Hint
There is no blank space at the end of each line.
一个简单的问题
问题描述
在这个问题中,你需要做一个N * N的乘法表,就像样本一样。i行和第j列中的元素应该是产品(乘积)i和j。
输入
输入的第一行是一个整数C,表示测试用例的数量。
然后是C测试用例。每个测试用例在上面提到的一行中包含一个整数N (1<=N<=9)。
输出
对于每个测试用例,打印乘法表。
样例输入
2
1
4
样例输出
1
1 2 3 4
2 4 6 8
3 6 9 12
4 8 12 16
提示
每行的末尾没有空格。
代码:
#include<stdio.h>
int main()
{
int i,t,n,j,k,f;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=1,j=1;i<=n;i++,j++)
{
f=i;
for(k=1;k<=n;i+=j,k++)
if(k==n)
printf("%d",i);
else
printf("%d ",i);
i=f;
printf("\n");
}
}
return 0;
}