hdu 2120 Ice_cream's world I

C语言题库

共 2379字,需浏览 5分钟

 · 2021-10-01

Ice_cream's world I

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2856    Accepted Submission(s): 1619


Problem Description

ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.

 


Input

In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.

 


Output

Output the maximum number of ACMers who will be awarded.
One answer one line.

 


Sample Input

8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7

 


Sample Output

3


Ice_cream的世界我


问题描述

冰淇淋的世界是一个富有的国家,它有许多肥沃的土地。今天,这位冰淇淋女王想把土地奖励给勤奋的ACMers。于是便设置了一些瞭望塔,并在瞭望塔之间筑起了墙,以划分冰淇淋的世界。但是,女王最多可以授予多少个ACMers是一个大问题。一个被墙包围的土地只能给一个ACMer并且不能越过墙,如果你能帮助女王解决这个问题,你将得到一块土地。


输入

在这种情况下,前两个整数N, M (N<=1000, M<=10000)表示瞭望塔的数量和墙的数量。瞭望塔的编号从0到N-1。接下来的M行,每一行包含两个整数A, B平均值A和B之间有一个墙(A和B是不同的)。以文件结束结束。


输出

输出将被授予的ACMers的最大数量。

一个回答,一行。


Sample Input

8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7

 

Sample Output

3


解题思路:把对应的灯塔看作顶点,把之间的围墙看作无向边,当整个图存在环的时候,形成一个地方。


代码:

#include<stdio.h>
int pre[1005];//pre[x]=y;树中x的前驱节点为y
int findset(int x)//x属于那个集合,即求x的根结点
{
if(pre[x]!=x)
return pre[x]=findset(pre[x]);
else
return x;
}
int union_set(int a,int b)//合并集合x,y
{
int x=findset(a);
int y=findset(b);
if(x==y)
return 1;
else
{
pre[x]=y;//顺序无所谓,2棵树合并为1棵,1棵树的根节点指向另一颗的根节点
return 0;
}
}
int main()
{
int i,n,m;
while(scanf("%d %d",&n,&m)!=EOF)
{
for(i=0;i<=n-1;i++)
pre[i]=i;
int sum=0;
for(i=1;i<=m;i++)
{
int a,b;
scanf("%d %d",&a,&b);
sum+=union_set(a,b);
}
printf("%d\n",sum);
}
return 0;
}


浏览 17
点赞
评论
收藏
分享

手机扫一扫分享

举报
评论
图片
表情
推荐
点赞
评论
收藏
分享

手机扫一扫分享

举报