hdu 2017 字符串统计
C语言题库
共 782字,需浏览 2分钟
·
2021-05-28 18:01
字符串统计
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 151795 Accepted Submission(s): 83529
Problem Description
对于给定的一个字符串,统计其中数字字符出现的次数。
Input
输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。
Output
对于每个测试实例,输出该串中数值的个数,每个输出占一行。
Sample Input
2
asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf
Sample Output
6
9
代码:
#include<stdio.h>
int main()
{
int n;
char s;
while(scanf("%d%*c",&n) !=EOF )
{
while(n--)
{
int num=0;
while(scanf("%c",&s) && s!='\n')
{
if((s>='0') && (s<='9')) num++;
}
printf("%d\n",num);
}
}
return 0;
}
评论