hdu 2051 Bitset

C语言题库

共 860字,需浏览 2分钟

 · 2021-07-13

Bitset

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 39967    Accepted Submission(s): 29177


Problem Description

Give you a number on base ten,you should output it on base two.(0 < n < 1000)

 


Input

For each case there is a postive number n on base ten, end of file.

 


Output

For each case output a number on base two.

 


Sample Input

1
2
3

 


Sample Output

1
10
11



代码:

#include<stdio.h>
int main()
{
int n,a[100];
while(~scanf("%d",&n))
{
int i=0,j;
while(n)
{
a[i++]=n%2;
n/=2;
}
for(j=i-1;j>0;--j)
{
  if(a[j]!=0)
  break;
}
for(;j>=0;--j)
{
printf("%d",a[j]);
}
printf("\n");
}
return 0;
}



浏览 34
点赞
评论
收藏
分享

手机扫一扫分享

举报
评论
图片
表情
推荐
点赞
评论
收藏
分享

手机扫一扫分享

举报