hdu 2053 Switch Game

共 1493字,需浏览 3分钟

 ·

2021-07-13 06:32

Switch Game

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 31802    Accepted Submission(s): 19449


Problem Description

There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).

 


Input

Each test case contains only a number n ( 0< n<= 10^5) in a line.

 


Output

Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).

 


Sample Input

1
5

 


Sample Output

1
0

Hint

hint



Consider the second test case:

The initial condition : 0 0 0 0 0 …
After the first operation : 1 1 1 1 1 …
After the second operation : 1 0 1 0 1 …
After the third operation : 1 0 0 0 1 …
After the fourth operation : 1 0 0 1 1 …
After the fifth operation : 1 0 0 1 0 …

The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.



代码:

#include <stdio.h>
int main()
{
int n;
int i;
int count;
while(~scanf("%d",&n))
{
count = 0;
for(i=1;i<=n;i++)
{
if(n%i == 0)
count++;
}

if(count%2==0)
printf("0\n");
else
printf("1\n");
}
return 0;
}


浏览 12
点赞
评论
收藏
分享

手机扫一扫分享

分享
举报
评论
图片
表情
推荐
点赞
评论
收藏
分享

手机扫一扫分享

分享
举报