poj 1003 Hangover

ACM比赛整理

共 2373字,需浏览 5分钟

 · 2022-11-18

Hangover


Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 150577
Accepted: 72728

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.



Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input

1.00
3.71
0.04
5.19
0.00

Sample Output

3 card(s)
61 card(s)
1 card(s)
273 card(s)




宿醉


描述

你能让一堆卡片悬在桌子上方多远?如果你有一张卡片,你可以创造出半张卡片长度的最大悬垂。(我们假设纸牌必须垂直于桌子。)用两张卡片,你可以使顶部的卡片悬在底部的卡片长度的一半,底部的卡片悬在桌子的卡片长度的三分之一,总的最大悬在1/2 + 1/3 = 5/6卡片长度。一般来说,你可以让n张卡片以1/2 + 1/3 + 1/4 +…+ 1/(n + 1)牌长,上面的牌比第二张高出1/2,第二张比第三张高出1/3,第三张比第四张高出1/4,等等,下面的牌比桌子高出1/(n + 1),如下图所示。

输入

输入由一个或多个测试用例组成,后面跟着一行包含数字0.00,表示输入的结束。每个测试用例都是包含一个浮点数c的单行,其值至少为0.01,最多为5.20;C正好包含三个数字。


输出

对于每个测试用例,输出所需的最小卡数,以达到至少c卡长度的悬垂。使用示例中所示的输出格式。


Sample Input

1.00
3.71
0.04
5.19
0.00

Sample Output

3 card(s)
61 card(s)
1 card(s)

273 card(s)



题意:求最小的n让1+1/2+1/3+...+1/n大于给的一个实数。

思路:找一个数sum记录结果,写一个循环不断累加 sum+=1.0/n,

直到sum大于c,输出n-2.


代码:

#include<stdio.h>
int main()
{
double c,sum;
int n,card;
while(scanf("%lf",&c)!=EOF&&c)
{
if((int)(c*100)==0)
break;
sum=0;
n=2;
while(sum<=c)//循环模拟。直到超过
{
sum+=1.0/n;
n++;
}
printf("%d card(s)\n",n-2);
}
return 0;
}


浏览 17
点赞
评论
收藏
分享

手机扫一扫分享

举报
评论
图片
表情
推荐
点赞
评论
收藏
分享

手机扫一扫分享

举报